[pptp-server] Errors 650 629 645

John Sutton john at scl.co.uk
Mon Jun 7 05:41:55 CDT 1999

At 13:36 07/06/99 +0800, you wrote:
>> >My Win98 LAN clients work from a clean boot with no problem.  Ditto Win95
>> >(with DUN update 1.3 + sockets fix, etc).  Trying it from a dialup here
>> Eek!  What is "sockets fix"?
>Unrelated to the problem (I hope).  However when I asked a group on campus
>who are already doing VPN under NT what was needed for a Win95 client, they
>told me to install DUN update 1.3 followed by sockets fix; I think that's
>also known as 'ws2setup'.  Don't have a URL for it except intranet ones.
>I think it's just a generally recommended thing for anyone still running Win95.

I'll look that up.  Maybe it's related...

>> You suggest it is either a firewall issue or a pppd issue.  Re firewall,
>> yes, there is a masquerading router between the linux server and the internet.
>> tcp        0      0        ESTABLISHED
>> So pptp is a simple single socket protocol, yes?
>No.  Look at the entry further down in netstat -na called "raw".
>> So I can't see why it should not be treated like any other such protocol?
>Because you're looking at the TCP control connection.  PPTP uses more than just
>that connection.  Look at pptpgre.c.
>> And the fact that this socket does get established when using a dialup
>> connection, at least temporarily, surely indicates that this is not the
>> source of the problem? [...]
>The control connection gets established, the real data connection doesn't I 
>suspect.  Your masquerading probably can't handle GRE.
>>From pptpgre.c:
>gre_fd = socket(AF_INET, SOCK_RAW, PPTP_PROTO);
>connect(gre_fd, (struct sockaddr *) &src_addr, sizeof(src_addr));
>PPTP_PROTO is protocol 47.  If you want to watch the pptp packets,
>try 'tcpdump proto 47' (but tcpdump doesn't understand them much =
>you just get meaningless stuff out of it).

Fool I am.  I now remember seeing mention of protocol 47.

However, I'm still not sure that this is the issue.  Two things:

1) The router in question is an Eicon Diva LAN ISDN Modem which proudly announces on the box that it supports PPTP.  Does this protocol use ports?  With the first word "source port/dest port" as with TCP & UDP?  Maybe it's flunking the masquerade?  I'll do a tcp dump as you suggest on the client and see what's happening.

2) If I make a direct ISDN call (and thereby can switch off masquerading) I get the same result.  I've only done this so far with the Win95 client so I can't see anything happening beyond the error 645 as before, but I'm seeing exactly the same in the pptpd log as before - it sends the LCP and gets nothing back.  I'll try it with the linux client and see what's going on.

I'll also try and get some info from Eicon!

Thanks for your help.  I'll report back if I make any progress.


John Sutton
SCL Computer Services
URL http://www.scl.co.uk/
Tel. +44 (0) 1239 621021

More information about the pptp-server mailing list