[pptp-server] Windows connection problems to PPTPD

Rick Lamb rblamb at home.com
Sun May 16 22:31:57 CDT 1999

I installed v0.8.4 onto my Redhat 5.2 system. The install went fine. I
am now trying to connect to the server from a Windows 98 machine.

When I connect without authentication, everything works fine. However,
when I try to use any authentication, it refuses to connect. The
following is my setup:

Windows 98 machine

Machine name : CR705434-B
NT Domain name : LAMB
IP :
Encrypt password : have tried enabled and disabled
Encrypt data : have tried enabled and disabled
PPTP Logon Setup:
  User Name : RLAMB
  Password : <password>
  VPR Server :

Linux machine

Machine name : LINUX
IP :

PPP options file
  name LINUX

PPTPD.conf file
  speed 115200

chap-secrets file
  RLAMB LINUX <password>

Then Linux machine is multihomed with a local IP of and a
cable modem IP of When I try to connect from the Windows
box, the connection flashes for a minute or so and then gives me a
message indicating it can't establish a  network connection with the
server. In my messages log and pppd log, I get an entry which reads:

  peer authentication required but no suitable secret(s) found for
authenticating any peer to us (linux)

I suspect my secrets file is not set up right (or something), but I
can't seem to stumble into the right answer. Can anyone help??


Rick Lamb

More information about the pptp-server mailing list