[pptp-server] Help - PPTP 1.0.0, PPP 2.8.10, RH6.1

Eric Stratte estradey at pullman.com
Sat Nov 6 17:02:09 CST 1999

Well, after thoroughly analyzing and trying most of the FAQ,
re-compiling the kernel, PPP, and PPTP multiple times, and trying lots
of options, hand hacking in the MS-DOMAIN// update and the RC4 stuff,
which compiles, but doesn't work, I am stumped.

What I am trying to do:

I have a linux firewall/masquerade on my ADSL(1 IP) connection on a P100
box, an 8 port hub, and a Win/linux machine.  I have also been having
LAN game parties from time to time.  I would like to setup PPTP to allow
TCP/IP and IPX into my local LAN so that we can have remote people join
in/share files, etc...

What I've tried:

straight PPTP 1.0 with noauth.  People can log in, I can ping both their
local and remote IP's with the linux box, but they don't seem to be on
the local network(I can ping their local(t <10ms), but not remote IP).
I have set the little arp hack in ip-up.local as mentioned in the FAQ.
I haven't added any special firewall forwarding rules, since it seems
like it is using an address on the internal subnet and the arp comand
lists it as being bound to the proper nic.  The ppp0 listing under
ifconfig comes up with NOARP, but it lets me turn it on after the
connection is made, but it doesn't seem to work either way.
If I connect to the PPTP server from the local LAN, I can ping both the
local and remote ip's of the machine I am on.
The remote guy can ping both of his addresses, as well.
One thing I think is worng that I haven't fixed yet is the pptp
modprobing for char-major-108, which it can't find.  I don't know what
this means...:(  But it still seems to connect and pass some packets ok.

The other thing that may be goofy is I tried initially with PPP-2.3.10,
then 2.3.8, then went back to 2.3.10.  I don't know if there was
someremenant of one that carried over?  I have re-compiled everything in
the order described in the FAQ.  PPP and IPX are compiled into my
kernel.  I did try PPTP with noauth on PPP before re-compiling anything,
and that had nearly identical results.

I can post pptp connection dumps, ifconfig, route, arp, even tcpdump :)
to here :( or on a website.

I hope I am doing something obviously wrong.  This is getting to the
point where I need to get out the PPTP white papar, and completely read
about arp, IPX, etc. and become an expert...

after this, I have to tackle the RC4 part, which doesn't work either...



More information about the pptp-server mailing list