[pptp-server] recompile of ppp-2.3.8 w/ mppe problem

Nick Jones nickj at coho.net
Sun Oct 10 16:49:49 CDT 1999

Hi everyone again.  I think I skipped a step when I originally tried to setup PPTPD.  I'm now trying to recompile pppd 2.3.8 w/ mppe and it fails on me.  I've followed the directions on the pptp website and I have tried starting over at least three to four times.  Below is the error it hangs up on:

  cc -O2 -pipe -Wall -g -D_linux_=1 -DHAVE_PATHS_H -DIPX_CHANGE -I../include  -DCHAPMS=1 -DUSE_CRYPT=1 -DMPPE=1 -DHAS_SHADOW -o pppd main.o magic.o fsm.o lcp.o ipcp.o upap.o chap.o md5.o ccp.o auth.o options.o demand.o utils.o sys-linux.o ipxcp.o cbcp.o mppe.o sha1dgst.o extra_crypto.o md4.o chap_ms.o  -lcrypt
  ld: cannot open -lcrypt: No such file or directory
  make[1]: *** [pppd] Error 1
  make[1]: Leaving directory `/root/ppp-2.3.8/pppd'
  make: *** [all] Error 2

I installed SSLeay 0.6.6b and tried installing a later version of it to try and fix the problem but it didn't seem to help.  I've also tried installing OpenSSL 0.9.4 in hope it would have the library which didn't help either.  If someone could help me on this that'd be great. Thanks all.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.schulte.org/mailman/private/pptp-server/attachments/19991010/9a7ae44b/attachment.html>

More information about the pptp-server mailing list