[pptp-server] Debian woody ppp-mppe source packages

Neale Banks neale at lowendale.com.au
Mon Jul 29 17:50:05 CDT 2002


On 29 Jul 2002, Sean McAvoy wrote:

> Hello,
> I've downloaded and applied the patch you provided. When I go to build
> the package (using dpkg-buildpackage) I get the following (I am building
> this as root): /usr/bin/dpkg-buildpackage: debian/rules: /usr/bin/make:
> bad interpreter: Permission denied

Hmmm... obviously this didn't happen for me - but nor did I use
dpkg-buildpackage: instead I ran "debian/rules build" then "debian/rules
binary".  BTW, there's no need to be root at this stage - use fakeroot

The obvious thing to check is that you have all the packages specified for
(IIRC) build-depends in the debian/control - something mising there could
provoke a bizzare error like this.

> Anyone else have similar problems, or am I just missing something stupid
> simple :)  ?

Well, it *is* equally possible that I've missed something simple ;-)

Please check/confirm the above points, and if it still doesn't work for
you I'll take a closer look here.

Thanks for the report,

More information about the pptp-server mailing list