[pptp-server] Connection Trouble - Burn XP!!!!!!!

Timothy Wilkes timw at paradise.net.nz
Sun Mar 3 03:47:05 CST 2002


I've set up a pptp server on SuSE Linux, using their pre built packages 
with all the patches for mppe etc, saving me some time :)

I can successfully connect a Windows 2000 Professional and even Linux 
client with the mppe-128 encryption and transfer data back and forth. 
But here comes problem...

When I tried it with Micro$ofts Windows XP Professional it establishes 
the connection, it claims to use MPPE 128, My Network Neighborhood or My 
network places or whatever they call it somehow display a list of 
machines on the Domain but I can't connect to any shares, the log on the 
Linux Server came up with a error with the XP connection, I also get the 
same error for MPPE 48:

"Not enough space to encrypt packet: 1404<1404+4!"

To my limited knowledge I think this means that the 128 mppe patch isn't 
there, but when I try with Win2k or Linux I get the happy message "PPP 
MPPE compression module registered". Low and behold I then tried XP with 
the encryption disabled and shock! gasp! horror!!!!! it worked perfectly.

Any ideas? Thanks


Have Micro$oft just rewritten their MPPE protocol to piss us of, I say 
we go over and bash Bill good... I shouldn't be surprised  I guess they 
do rewrite the protocols every service pack and new release of windows...

More information about the pptp-server mailing list