[pptp-server] Kernel panic with 2.4.17-2.4.19pre2 + Win98 client

Nate Carlson natecars at real-time.com
Thu Mar 14 14:51:13 CST 2002

Hey guys,

Been having a really weird issue with one of our clients.

We've got PPTPD (tried both 1.0.1 and 1.1.2) running on a gateway box we
put out at a client site, and whenever a client connects to it with
Windows 98 or Windows 98se and transfers a big file, the Linux box goes
into a kernel panic with the process 'pptpctrl', and locks hard.

Kernel is fairly vanilla. The kernel we are running right now is
2.4.19pre2 with the 'linux-2.4.16-openssl-0.9.6b-mppe.patch' patch. We've
tried 2.4.17 with much older patches, and 2.4.18 with the above patches;
neither works.

We're running PPPD v2.4.1 with the following patches:


If we turn off encryption, everything works fine, and if we connect from a
Windows 2000 or Windows XP system, everything works fine (with encryption
turned on). We've swapped the machine running pptpd out; exact same
symptoms. Nothing weird running on the box, except for typical iptables
modules and such.

I've attached the ksymoops output of the kernel panic; anyone have any
ideas on what could possibly cause this?

Nate Carlson <natecars at real-time.com>   | Phone : (952)943-8700
http://www.real-time.com                | Fax   : (952)943-8500

More information about the pptp-server mailing list