[pptp-server] Problems: Server works but link slowly dies off with any client

Tony Skinner tlskinner at mail.mv.total-web.net
Sun Nov 21 19:21:12 CST 1999


	I am using PoPToP v1.0.0, ppp-2.3.10 with latest patches and kernel
2.2.13. I have the server and client establishing link and passing data;
however, after 2-3 minutes of connectivity with the server, the connection
begins to gradually slow down. Initially when the connection is made,
everything is fast and responsive, but as time passes, the link grows
slower until finally it ceases to respond. 

	The logs reveal checksum errors being reported from pppd. The errors occur
at random times. In some cases, the connection can last up to 5-10 minutes
while others last 20 seconds. I have reproduced these errors regardless of
the transmission medium. I have established tunnels via modem over the net
to the server. I have tested on the local network to the server
establishing a tunnel over a 100 mb connection. The same symptoms
everytime, increased slowness until finally the link ceases to function. I
have tried disabling certain options with the microsoft vpn connection
client which has no affect on the connection dying. I have also tried
various tricks within the /etc/ppp/options file for helping with
transmission errors, this has had no effect at all.

	Is anyone out there successfully using PoPToP with encryption without any
of these symptoms? If so, please respond. I would be interested to see how
your configuration differs from mine. At this point, I am wondering if it
has something to do with the kernel version I am running.

	Thanks in advance,
	Tony Skinner

More information about the pptp-server mailing list