[pptp-server] FreeBSD, Samba, PoPToP Connection Problems (internally and externally)

Ivan Fetch ivanfetch at technologist.com
Tue Aug 1 01:27:36 CDT 2000

   Have you ever tried connecting to your external interface via a windows
machine which is not going through a firewall, but instead is directly
connected to the Internet?  This could help to narrow down your problem.

  If you are using natd on the other FreeBSD gateways (the ones you are
trying to connect to your VPn machine through) you need to specify
something like this to natd.  I have my natd_flags set to "-f
/etc/natd.conf" - This file contains:
unregistered_only yes

The address is the address of a machine I would like to be
allowed to use VPN through that gateway.  You can only do this with *one*
machine.  If you have a need to do this with more than one machine perhaps
you could look at VPN'ing the two gateways together <?>.

Hopefully some of this will help, if not please let me know and I will see
what else I can do.

Ivan Fetch.

On Tue, 1 Aug 2000, Charles Peters - Tech Support wrote:

> Greetings:
> I have a FreeBSD 4.0 server running Samba 2.0.7, and PoPToP-
> 1.0.0.  I have 2 network interface cards in this machine, one with 
> an internal ip address ( and the other with an external 
> ip address (24.4.xxx.xxx).  This machine is connected to the 
> internet via a cable modem, and is also connected to a lan on 
> 192.168.0.
> My Windows 98 computer is also connected to the lan, with an ip 
> address of  When this machine attempts to establish 
> a vpn connection to the internal interface (, the 
> connection is allowed, but when I try and connect to the external 
> network card from the win 98 box, I get the following error:
> 	Error 629:  You have been disconnected from the computer
> 	that you dialed. Double click the connection to try again.
> I also get the same error from computers accross the internet 
> attempting to connect to the external adapter.  These other 
> computers are also on lans, but have internet access via a cable 
> modem and a freebsd gateway running nat and ipfw.  Computers 
> connected to the internet via real connections (no nat) also get the 
> same error message.
> My first concern is where these connection rejection messages 
> appear, they don't show up in /var/log/messages or 
> /var/log/ppp.conf.
> Secondly, how do I fix the problem. As far as I can tell, the vpn is 
> working properly inside the lan, the problem is in connecting from 
> outside the lan.
> It should be noted that I am attempting to connect thru a freebsd 
> gateway running ipfw and nat.  The firewall type is OPEN.
> Any help would be appreciated, as I have spent a considerable 
> amount of time and effort on this project, and am no closer to a 
> solution after about 30 hours.  Maybe it's time to cut my loses, and 
> find another method for establishing a vpn.  Suggestions to this end 
> are also appreciated.
> Thanks in Advance!!!
> Charles
> support at tecpro.com
> Charles Peters
> mailto:support at tecpro.com
> _______________________________________________
> pptp-server maillist  -  pptp-server at lists.schulte.org
> http://lists.schulte.org/mailman/listinfo/pptp-server
> List services provided by www.schulteconsulting.com!

More information about the pptp-server mailing list