[pptp-server] problem in invoking the daemon

Murali K. Vemuri muralivemuri at multitech.co.in
Mon Mar 4 00:29:02 CST 2002


i have a strange problem.
i have web based UI for my VPN box and the pages are PHP.
the PHP calls a perl script by name 'setpptp' and the perl script
invokes the daemon.
when i run the perl script from the shell, i can run the daemon and
everything is fine.
but, when i do the same from the PHP, the browser hangs.
curiously, i checked the processes with 'ps -e | grep pptp'
and to stunn me, pptp is invoked and there is another process
'setpptp <defunct>'
so, checked the permissions, user name, group etc....etc....etc....
everything is fine
then i went and wrote a shell script in place of a perl script.
still the same thing ..... no progress and the browser still hangs.
and to add, here also, if i try to kill 'setpptp' process, i cound never
do it.
and if i kill 'pptpd', setpptp also comes out.
so, i tried to invoke the daemon as a background process with an '&'
.... still .....nope!
any ideas?

regards & thanks for your time,
Murali Krishna Vemuri
--All blue, I write with a Blue Pencil on a Blue Sky.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.schulte.org/mailman/private/pptp-server/attachments/20020304/425b1d60/attachment.html>

More information about the pptp-server mailing list