[pptp-server] poptop, mppe, and ppp cvs

Alex King alex at morrison.king.net.nz
Wed May 8 03:59:15 CDT 2002

I'm getting nowhere fast in my attempt to set up poptop with debian
linux :(

to recap, I run:

Debian woody, with pptpd 1.1.2 (standard woody package)
pppd pulled from CVS at www.samba.org.
kernel 2.4.19-pre8, patched with the three patches for 2.4.18 in the
pppd cvs sources.

It's not that I necessarily WANT to run the latest of everything, but
there seems to be a whole lot of conflicting info out there about where
to obtain and how to set up poptop.  I thought that the latest would be
most likely to work the best, perhaps I'm wrong....

Where I'm at - I can connect using a win95/DUN1.4 client with CHAP and no
encryption.  If tick "Require encrypted password" on the cient, I can
still connect:

sent [LCP ConfReq id=0x1 <asyncmap 0x0> <auth chap MD5> <magic 0x70690983>
<pcomp> <accomp>]
rcvd [LCP ConfAck id=0x1 <asyncmap 0x0> <auth chap MD5> <magic 0x70690983>
<pcomp> <accomp>]
sent [CHAP Challenge id=...
rcvd [CHAP Response...
sent [CHAP Success...

and the connection succeeds

When I configure the server with require-mschap-v2 I get:
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <auth chap MS-v2> <magic 0x8c3d3f60>
<pcomp> <accomp>]
rcvd [LCP ConfAck id=0x1 <asyncmap 0x0> <auth chap MS-v2> <magic 0x8c3d3f60>
<pcomp> <accomp>]
sent [CHAP Challenge...
rcvd [CHAP Response...
sent [CHAP Success...
sent [IPCP ConfReq id=0x1 <addr> <compress VJ 0f 01>]
sent [CCP ConfReq id=0x1 <deflate 15> <deflate(old#) 15> <bsd v1 15>]
CHAP peer authentication succeeded for workgroup\\alex
rcvd [LCP ProtRej id=0x2 80 fd 01 01 00 0f 1a 04 78 00 18 04 78 00 15 03 2f]
rcvd [LCP TermReq id=0x3]

and the connection fails (note I have workgroup\\alex in the chap

Here is my main question:

What should I do to get a working setup?  Should I go back to 2.4.18, or
an earlier 2.4 with other patches, or even back to 2.2 kernel?  Is my
configuration worng?  Is it a client issue? (I tried the linux pptp
client, but I found mail list notes saying this does not work with later
2.4 kernels, and I could not get it going even unencrypted.)  It is more
difficult for me to test against win98, but I would do that if I thought
I'd have a better chance.

What is the significance of the ProtRej line second to last in the above
log?  Has anyone got a poptop to work in a similar setup (ie, kernel
2.4.18 or 2.4.19 with mschap-v2 and mppe encryption?)

I intend to solve this problem tonight...... :^P


More information about the pptp-server mailing list