[pptp-server] speed issues and ppp.c compile problems

Adam Tauno Williams adam at morrison-ind.com
Tue Aug 1 13:56:33 CDT 2000

>After successfully installing pptp and friends on a 486-66 box, we found
>that the VPN established was so slow as to be unusable--even with a T1
>connection on the server side and a cable modem (600+Kbps downstream,
>128+Kbps upstream) on the client side.  My first question then is, What
>are the minimum hardware requirements for the PoPToP Server?  I should
>add that our main goal is to run a client application over the VPN.
>(The software is a print-management system for the commercial printing
>industry running on an NT box with MS SQL Server.  The NT pptp server
>wouldn't work at all and, besides, it's Not Scottish!)

My VPN server is a 486DX133 with 20Mb.  Handles up to 5 connects, and fast.

>I am already trying to re-install on a P133 box, but have run into
>compilation problems.  I am using a stock Red Hat 2.2.14 kernel and
>tarballs of OpenSSL 0.9.5 and ppp-2.3.11.  I applied the appropriate
>ppp/openssl/mppe patch before compiling, but when I ran "make modules"
>it bombed out on the ppp.c compile, giving errors to the effect of
>"static declaration for X follows non-static" where X is
>ppp_register_compressor and ppp_unregister_compressor.  Did I miss a
>patch somewhere or must I be running a 2.2.16 kernel?

Have you tried using the "clean" source from ftp.kernel.org.  Redhat kernel
source RPMS contain other patches.  (And I've have no luck with 2.2.16).

More information about the pptp-server mailing list