[pptp-server] Re: smbpasswd for pppd

James MacLean macleajb at EDnet.NS.CA
Wed May 17 10:13:22 CDT 2000

Hi Mike,

Some obvious things first:

. does /etc/smbpasswd have the exact name u used on the connect request?
. have you tried /etc/ppp/chap-secrets with just a single line as such:
* * &/etc/smbpasswd *
. if you put back in /etc/ppp/chap-secrets the normal lines to
  connect, does the new pppd still function as it use to?

and last :) are you testing your connects only from Windows client? Or
have you tested pptp too?


On Wed, 17 May 2000 michael.kappler at primedisc.com wrote:
> Hi James,
> I've tried to patch my ppp-2.3.11 with the pppsmb.pat and added the
> appropriate line pointing to my smbpsswd-file
> to /etc/ppp/chap-secrets and installed libsmbpw. My linux VPN is running on
> a 2.2.13 kernel, pptpd 1.0.0 and samba 2.0.5a.
> Nothing happened.
> Error messages like:
> The remote system is requiered to authenticate itself
> but I couldn't find any suitable secret (password) for it to use to do so.
> (None of the available passwords would let it use an IP address).
> I'm also using the strip-MSdomain-patch which stripps off the domain name
> and \\ from Win clients
> before checking the chap-secrets file.
> Do you have any idea what went wrong?
> Thanks
> Mike

James B. MacLean        macleajb at ednet.ns.ca
Department of Education http://www.ednet.ns.ca/~macleajb
Nova Scotia, Canada
B3M 4B2

More information about the pptp-server mailing list